Requis pour l'installation

PHP 5.5+ requière au moins Windows 2008/Vista, ou 2008r2, 2012, 2012r2, 2016 or 7, 8, 8.1, 10. Soit 32-Bit, soit 64-bit (aka X86 ou X64. PHP ne fonctionne pas sous Windows RT/WOA/ARM). Depuis PHP 7.2.0 Windows 2008 et 7 ne sont plus pris en charge.

PHP requière Visual C runtime(CRT). Plusieurs applications le requière, aussi, il doit déjà être installé.

PHP 5.5 et 5.6 requièrent VC CRT 11 (Visual Studio 2012). Voir : » https://www.microsoft.com/en-us/download/details.aspx?id=30679

PHP 7.0+ requière VC CRT 14 (Visual Studio 2015). Voir : » https://www.microsoft.com/en-us/download/details.aspx?id=48145

Vous DEVEZ télécharger x86 CRT pour la compilation PHP x86 et x64 CRT pour la compilation PHP x64.

Si CRT est déjà installé, l'installeur vous le demandera, vous n'avez rien à changer.

L'installeur CRT supporte les options de ligne de commande /quiet et /norestart, aussi, vous pouvez les utiliser dans vos scripts.

VC11 CRT DLLs peuvent être copiés depuis votre machine locale vers une machine distante (une installation `Copy Deployment`) au lieu d'exécuter l'installeur sur la machine distante (comme un serveur web où vous auriez un accès restreint). Voir : http://www.sitepoint.com/install-php53-windows/

VC14 CRT ne supporte pas une installation `Copy Deployment`. VC14 CRT a beaucoup plus de DLLs (la plupart avec des noms commençant par api-*). Si vous arrivez à tous les trouver, et tous les copier, ca devrait aussi fonctionner (essayer un outil comme Resource Hacker pour récupérer une liste de tous les DLLs à copier).

add a note add a note

User Contributed Notes 1 note

up
-9
questorx1998-jd at yahoo dot com
4 months ago
What this effectively means is that users who used php in a portable fashion (eg as a wamp setup on a usb stick) have now been put into a position where they can no longer do so without having to install other runtimes - potentially a menace if using another person or organisations computer where they refuse to allow other software installation.
To Top